After much testing, we've determined that this performance degradation was limited to only a few customers and the domain transfer tool remains functional for most. We're leaving this incident up while we confirm that no other customers are affected, and will update here as soon as we confirm that the situation is resolved.
Posted Oct 22, 2025 - 08:31 CDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2025 - 15:08 CDT
Investigating
Customers are currently unable to point domains to StellarSites from their account portal. We are investigating the issue and will update here once it's resolved.